package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]{2,3}([-\/][a-zA-Z]{2,3})?$`)
var str = `XX
XXX
XX-XX
XXX-XX
XXX-XXX
XX-XXX
XX/XX
XXX/XX
XXX/XXX
XX/XXX`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}