re = /^[a-zA-Z]{2,3}([-\/][a-zA-Z]{2,3})?$/m
str = 'XX
XXX
XX-XX
XXX-XX
XXX-XXX
XX-XXX
XX/XX
XXX/XX
XXX/XXX
XX/XXX'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end