using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^a-zA-Z]|^)(?:X-Men|prof[esor]{0,6}\.{0,1} x|wolverine|new mutant|captain britain|x-force|magneto|cyclops|chris claremont|deadpool|kamala khan|orchis|emma frost|magik|illyana rasputin|illyana rasputina|boom-boom|carol danvers|krakoa|alpha flight|starjammer|house of x|powers of x|fall of x|krakoa|x-feed|xmen|x men|#xmen|betsy braddock|x-tober|x-tober24|nightcrawler|#x-men|#x-tober2024|x-statix|krakoan)(?:[^a-zA-Z]|$)";
string input = @"deadpool";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}