import re
regex = re.compile(r"(?:[^a-zA-Z]|^)(?:X-Men|prof[esor]{0,6}\.{0,1} x|wolverine|new mutant|captain britain|x-force|magneto|cyclops|chris claremont|deadpool|kamala khan|orchis|emma frost|magik|illyana rasputin|illyana rasputina|boom-boom|carol danvers|krakoa|alpha flight|starjammer|house of x|powers of x|fall of x|krakoa|x-feed|xmen|x men|#xmen|betsy braddock|x-tober|x-tober24|nightcrawler|#x-men|#x-tober2024|x-statix|krakoan)(?:[^a-zA-Z]|$)", flags=re.MULTILINE)
test_str = "deadpool"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")