import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:[^a-zA-Z]|^)(?:X-Men|prof[esor]{0,6}\\.{0,1} x|wolverine|new mutant|captain britain|x-force|magneto|cyclops|chris claremont|deadpool|kamala khan|orchis|emma frost|magik|illyana rasputin|illyana rasputina|boom-boom|carol danvers|krakoa|alpha flight|starjammer|house of x|powers of x|fall of x|krakoa|x-feed|xmen|x men|#xmen|betsy braddock|x-tober|x-tober24|nightcrawler|#x-men|#x-tober2024|x-statix|krakoan)(?:[^a-zA-Z]|$)";
final String string = "deadpool";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}