#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{1,10}|(?![\d.]{11,})\d+\.\d+)$"
Local $sString = "1" & @CRLF & _
"12" & @CRLF & _
"12345" & @CRLF & _
"1234567890" & @CRLF & _
"12345678901" & @CRLF & _
"1.23" & @CRLF & _
"3.14159" & @CRLF & _
"1.12345678" & @CRLF & _
"1.123456789"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")