re = /^(?:\d{1,10}|(?![\d.]{11,})\d+\.\d+)$/m
str = '1
12
12345
1234567890
12345678901
1.23
3.14159
1.12345678
1.123456789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end