using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\d{1,10}|(?![\d.]{11,})\d+\.\d+)$";
string input = @"1
12
12345
1234567890
12345678901
1.23
3.14159
1.12345678
1.123456789";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}