const regex = /^(?:\d{1,10}|(?![\d.]{11,})\d+\.\d+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d{1,10}|(?![\\d.]{11,})\\d+\\.\\d+)$', 'gm')
const str = `1
12
12345
1234567890
12345678901
1.23
3.14159
1.12345678
1.123456789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}