const regex = /^(?:\\b\\w+\\b[_!?\\s\\r\\n]*){3,7}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\\\b\\\\w+\\\\b[_!?\\\\s\\\\r\\\\n]*){3,7}$', '')
const str = `ash asdg sdg asd adsw `;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);