$re = '/^(?:\\\\b\\\\w+\\\\b[_!?\\\\s\\\\r\\\\n]*){3,7}$/';
$str = 'ash asdg sdg asd adsw ';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;