import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?s)(?:START).*?(?:END)(?-s)|//.+|\\. old|^\\s+old(*SKIP)(*FAIL)|\\b(old)\\b";
final String string = "xx START xx old xx END xx --> ignore\n"
+ "xx old xx --> REPLACE !\n"
+ "START xx old --> ignore\n"
+ " xx old xx END --> ignore\n"
+ " xx old xx --> REPLACE !\n"
+ "// xx old --> ignore\n"
+ "xx // xx old --> ignore\n"
+ "xx . old old xx --> ignore first one, replace second one\n"
+ ".\n"
+ " old --> ignore\n"
+ " (old) xx --> REPLACE !\n"
+ "xx old xx --> REPLACE !";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}