re = /(?s)(?:START).*?(?:END)(?-s)|\/\/.+|\. old|^\s+old(*SKIP)(*FAIL)|\b(old)\b/m
str = 'xx START xx old xx END xx --> ignore
xx old xx --> REPLACE !
START xx old --> ignore
xx old xx END --> ignore
xx old xx --> REPLACE !
// xx old --> ignore
xx // xx old --> ignore
xx . old old xx --> ignore first one, replace second one
.
old --> ignore
(old) xx --> REPLACE !
xx old xx --> REPLACE !'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end