import re
regex = re.compile(r"(?s)(?:START).*?(?:END)(?-s)|//.+|\. old|^\s+old(*SKIP)(*FAIL)|\b(old)\b", flags=re.MULTILINE)
test_str = ("xx START xx old xx END xx --> ignore\n"
"xx old xx --> REPLACE !\n"
"START xx old --> ignore\n"
" xx old xx END --> ignore\n"
" xx old xx --> REPLACE !\n"
"// xx old --> ignore\n"
"xx // xx old --> ignore\n"
"xx . old old xx --> ignore first one, replace second one\n"
".\n"
" old --> ignore\n"
" (old) xx --> REPLACE !\n"
"xx old xx --> REPLACE !")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")