package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-zA-z0-9]*[0-9]+[a-zA-Z0-9]*\b`)
var str = `https://stackoverflow.com/v1/summary/1243PQ/details/P1/9981/P1P1P1P`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}