use strict;
my $str = 'https://stackoverflow.com/v1/summary/1243PQ/details/P1/9981/P1P1P1P';
my $regex = qr/\b[a-zA-z0-9]*[0-9]+[a-zA-Z0-9]*\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}