const regex = /\b[a-zA-z0-9]*[0-9]+[a-zA-Z0-9]*\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-zA-z0-9]*[0-9]+[a-zA-Z0-9]*\\b', 'gm')
const str = `https://stackoverflow.com/v1/summary/1243PQ/details/P1/9981/P1P1P1P`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}