// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[a-zA-z0-9]*[0-9]+[a-zA-Z0-9]*\b").unwrap();
let string = "https://stackoverflow.com/v1/summary/1243PQ/details/P1/9981/P1P1P1P";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}