#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "class(?=="(?:field|.*?\sfield|field\s.*?)")"
Local $sString = "Ex1: should match both of these:" & @CRLF & _
"" & @CRLF & _
"<div class="something else field">Foo</div>" & @CRLF & _
"<div class="field something else">Foo</div>" & @CRLF & _
"<span class="field">Bar</span>" & @CRLF & _
"Ex2: should not match" & @CRLF & _
"" & @CRLF & _
"<div class="baseball-field baz">Baz</div>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")