using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"class(?==""(?:field|.*?\sfield|field\s.*?)"")";
string input = @"Ex1: should match both of these:
<div class=""something else field"">Foo</div>
<div class=""field something else"">Foo</div>
<span class=""field"">Bar</span>
Ex2: should not match
<div class=""baseball-field baz"">Baz</div>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}