use strict;
my $str = 'Ex1: should match both of these:
<div class="something else field">Foo</div>
<div class="field something else">Foo</div>
<span class="field">Bar</span>
Ex2: should not match
<div class="baseball-field baz">Baz</div>
';
my $regex = qr/class(?=="(?:field|.*?\sfield|field\s.*?)")/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}