import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "class(?==\"(?:field|.*?\\sfield|field\\s.*?)\")";
final String string = "Ex1: should match both of these:\n\n"
+ "<div class=\"something else field\">Foo</div>\n"
+ "<div class=\"field something else\">Foo</div>\n"
+ "<span class=\"field\">Bar</span>\n"
+ "Ex2: should not match\n\n"
+ "<div class=\"baseball-field baz\">Baz</div>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}