$re = '/class(?=="(?:field|.*?\sfield|field\s.*?)")/';
$str = 'Ex1: should match both of these:
<div class="something else field">Foo</div>
<div class="field something else">Foo</div>
<span class="field">Bar</span>
Ex2: should not match
<div class="baseball-field baz">Baz</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);