using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=src="")(.*?)\s+(.*?)(?=\.)";
string substitution = @"$1_$2";
string input = @"text here
<img src=""foo_image.gif"" height=""42"" width=""42"">
text here
<img height=""42"" width=""42"" src=""another_foo image.png"" height=""42"" width=""42"">
text here
<img src=""/path/to/yetanother foo image.jpg"" height=""42"" width=""42"">
text here";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}