use strict;
my $str = 'text here
<img src="foo_image.gif" height="42" width="42">
text here
<img height="42" width="42" src="another_foo image.png" height="42" width="42">
text here
<img src="/path/to/yetanother foo image.jpg" height="42" width="42">
text here';
my $regex = qr/(?<=src=")(.*?)\s+(.*?)(?=\.)/xp;
my $subst = '$1_$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";