# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?<=src=")(.*?)\s+(.*?)(?=\.)
"""
test_str = ("text here\n"
"<img src=\"foo_image.gif\" height=\"42\" width=\"42\">\n"
"text here\n"
"<img height=\"42\" width=\"42\" src=\"another_foo image.png\" height=\"42\" width=\"42\">\n"
"text here\n"
"<img src=\"/path/to/yetanother foo image.jpg\" height=\"42\" width=\"42\">\n"
"text here")
subst = "$1_$2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.