import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=src=\")(.*?)\\s+(.*?)(?=\\.)";
final String string = "text here\n"
+ "<img src=\"foo_image.gif\" height=\"42\" width=\"42\">\n"
+ "text here\n"
+ "<img height=\"42\" width=\"42\" src=\"another_foo image.png\" height=\"42\" width=\"42\">\n"
+ "text here\n"
+ "<img src=\"/path/to/yetanother foo image.jpg\" height=\"42\" width=\"42\">\n"
+ "text here";
final String subst = "$1_$2";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}