re = /(?<=src=")(.*?)\s+(.*?)(?=\.)/x
str = 'text here
<img src="foo_image.gif" height="42" width="42">
text here
<img height="42" width="42" src="another_foo image.png" height="42" width="42">
text here
<img src="/path/to/yetanother foo image.jpg" height="42" width="42">
text here'
subst = '$1_$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result