import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/(.+)/sphericals/(.+)/(.{22}).([0-9].jpg)";
final String string = "/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/cubes/sphericals/TS/TS7013.col-panorama_sh.4.jpg";
final String subst = "/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/images/\\1/rgb/4096/\\2/\\3/\\4";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}