const regex = new RegExp('/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/(.+)/sphericals/(.+)/(.{22}).([0-9].jpg)', '')
const str = `/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/cubes/sphericals/TS/TS7013.col-panorama_sh.4.jpg`;
const subst = `/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/images/\1/rgb/4096/\2/\3/\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);