re = /\/mnt\/pond\/processed\/industry-data\/anadarko\/lucius\/inspections\/20191214\/(.+)\/sphericals\/(.+)\/(.{22}).([0-9].jpg)/
str = '/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/cubes/sphericals/TS/TS7013.col-panorama_sh.4.jpg'
subst = '/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/images/\\1/rgb/4096/\\2/\\3/\\4'
result = str.sub(re, subst)
# Print the result of the substitution
puts result