import re
regex = re.compile(r"/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/(.+)/sphericals/(.+)/(.{22}).([0-9].jpg)")
test_str = "/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/cubes/sphericals/TS/TS7013.col-panorama_sh.4.jpg"
subst = "/mnt/pond/processed/industry-data/anadarko/lucius/inspections/20191214/images/\\1/rgb/4096/\\2/\\3/\\4"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)