using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'([^""']*)'";
string input = @"RESPONSE(1, -2.532 + 0.779*(LN('Loss_Ratio')) +SELECT(INDEX_FIRST_TRUE('POL_Zero'=""No""),2.261,0.0) +SELECT(INDEX_FIRST_TRUE('POL_children'=""Si""),0.307,0.0))
RESPONSE(1, -2.532 + 0.779*(LN('Loss_Ratio')) +SELECT(INDEX_FIRST_TRUE('POL_Zero'=""Nos' conditional""),2.261,0.0) +SELECT(INDEX_FIRST_TRUE('POL_children'=""Si""),0.307,0.0))";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}