use strict;
my $str = 'RESPONSE(1, -2.532 + 0.779*(LN(\'Loss_Ratio\')) +SELECT(INDEX_FIRST_TRUE(\'POL_Zero\'="No"),2.261,0.0) +SELECT(INDEX_FIRST_TRUE(\'POL_children\'="Si"),0.307,0.0))
RESPONSE(1, -2.532 + 0.779*(LN(\'Loss_Ratio\')) +SELECT(INDEX_FIRST_TRUE(\'POL_Zero\'="Nos\' conditional"),2.261,0.0) +SELECT(INDEX_FIRST_TRUE(\'POL_children\'="Si"),0.307,0.0))';
my $regex = qr/'([^"']*)'/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}