// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"'([^"']*)'"#).unwrap();
let string = "RESPONSE(1, -2.532 + 0.779*(LN('Loss_Ratio')) +SELECT(INDEX_FIRST_TRUE('POL_Zero'=\"No\"),2.261,0.0) +SELECT(INDEX_FIRST_TRUE('POL_children'=\"Si\"),0.307,0.0))
RESPONSE(1, -2.532 + 0.779*(LN('Loss_Ratio')) +SELECT(INDEX_FIRST_TRUE('POL_Zero'=\"Nos' conditional\"),2.261,0.0) +SELECT(INDEX_FIRST_TRUE('POL_children'=\"Si\"),0.307,0.0))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}