import re
regex = re.compile(r"'([^\"']*)'")
test_str = ("RESPONSE(1, -2.532 + 0.779*(LN('Loss_Ratio')) +SELECT(INDEX_FIRST_TRUE('POL_Zero'=\"No\"),2.261,0.0) +SELECT(INDEX_FIRST_TRUE('POL_children'=\"Si\"),0.307,0.0))\n\n"
"RESPONSE(1, -2.532 + 0.779*(LN('Loss_Ratio')) +SELECT(INDEX_FIRST_TRUE('POL_Zero'=\"Nos' conditional\"),2.261,0.0) +SELECT(INDEX_FIRST_TRUE('POL_children'=\"Si\"),0.307,0.0))")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")