# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-z] [a-z](*SKIP)(*FAIL)| /_/gi;t' <<< "英文 中文 English something else"