import re
regex = re.compile(r"[a-z] [a-z](*SKIP)(*FAIL)| ", flags=re.IGNORECASE)
test_str = "英文 中文 English something else"
subst = "_"
result = regex.sub(subst, test_str)
if result:
print(result)