re = /[a-z] [a-z](*SKIP)(*FAIL)| /i
str = '英文 中文 English something else'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result