const regex = /[a-z] [a-z](*SKIP)(*FAIL)| /gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z] [a-z](*SKIP)(*FAIL)| ', 'gi')
const str = `英文 中文 English something else`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);