# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?m)^(?:([^""\n][^,\n]*|(?:""([^""]*(?:""""[^""]*)*)""))(?:,|$)){2}.*$/[$1]/ig;t' <<< "\"0x00030002\",\"What do you want to eat?\",\"\"
0x00030002,What do you want to eat?,
\"0x00000000\",\"What do you want to eat? fish, meat or
eggs?\",\"\"
0x00030002,\"Do you want \"\"meat\"\"?\","