package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?m)^(?:([^""\n][^,\n]*|(?:""([^""]*(?:""""[^""]*)*)""))(?:,|$)){2}.*$`)
var str = `"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
"0x00000000","What do you want to eat? fish, meat or
eggs?",""
0x00030002,"Do you want ""meat""?",`
var substitution = "[$1]"
fmt.Println(re.ReplaceAllString(str, substitution))
}