import Foundation
let pattern = #"(?m)^(?:([^""\n][^,\n]*|(?:""([^""]*(?:""""[^""]*)*)""))(?:,|$)){2}.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
"0x00000000","What do you want to eat? fish, meat or
eggs?",""
0x00030002,"Do you want ""meat""?",
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$1]"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)