using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^(?:([^""\n][^,\n]*|(?:""([^""]*(?:""""[^""]*)*)""))(?:,|$)){2}.*$";
string substitution = @"[$1]";
string input = @"""0x00030002"",""What do you want to eat?"",""
0x00030002,What do you want to eat?,
""0x00000000"",""What do you want to eat? fish, meat or
eggs?"",""
0x00030002,""Do you want ""meat""?"",";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}