use strict;
my $str = '"0x00030002","What do you want to eat?",""
0x00030002,What do you want to eat?,
"0x00000000","What do you want to eat? fish, meat or
eggs?",""
0x00030002,"Do you want ""meat""?",';
my $regex = qr/(?m)^(?:([^""\n][^,\n]*|(?:""([^""]*(?:""""[^""]*)*)""))(?:,|$)){2}.*$/ip;
my $subst = '[$1]';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";