import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(owner/repo)?#(\\d+)\\b|https?://github\\.com/([^/]+/[^/]+/(?:issues|pull))/(\\d+)(#issue(comment)(-)\\d+)?)";
final String string = "#123\n"
+ "https://github.com/owner/repo/issues/123\n"
+ "https://github.com/shoptet/sofa/pull/456\n"
+ "owner/repo#123\n"
+ "https://github.com/owner/repo/issues/123#issuecomment-123456789\n";
final String subst = "[\\1#\\2\\4\\7\\6](https://github.com/owner/repo/issues/\\2\\4\\5)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}