$re = '~(?:(owner/repo)?#(\d+)\b|https?://github\.com/([^/]+/[^/]+/(?:issues|pull))/(\d+)(#issue(comment)(-)\d+)?)~mi';
$str = '#123
https://github.com/owner/repo/issues/123
https://github.com/shoptet/sofa/pull/456
owner/repo#123
https://github.com/owner/repo/issues/123#issuecomment-123456789
';
$subst = "[\1#\2\4\7\6](https://github.com/owner/repo/issues/\2\4\5)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;