import Foundation
let pattern = ##"(?:(owner/repo)?#(\d+)\b|https?://github\.com/([^/]+/[^/]+/(?:issues|pull))/(\d+)(#issue(comment)(-)\d+)?)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
#123
https://github.com/owner/repo/issues/123
https://github.com/shoptet/sofa/pull/456
owner/repo#123
https://github.com/owner/repo/issues/123#issuecomment-123456789
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = ##"[\1#\2\4\7\6](https://github.com/owner/repo/issues/\2\4\5)"##
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)