const regex = new RegExp('(?:(owner/repo)?#(\\d+)\\b|https?://github\\.com/([^/]+/[^/]+/(?:issues|pull))/(\\d+)(#issue(comment)(-)\\d+)?)', 'gmi')
const str = `#123
https://github.com/owner/repo/issues/123
https://github.com/shoptet/sofa/pull/456
owner/repo#123
https://github.com/owner/repo/issues/123#issuecomment-123456789
`;
const subst = `[\1#\2\4\7\6](https://github.com/owner/repo/issues/\2\4\5)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);