// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)(?:(owner/repo)?#(\d+)\b|https?://github\.com/([^/]+/[^/]+/(?:issues|pull))/(\d+)(#issue(comment)(-)\d+)?)").unwrap();
let string = "#123
https://github.com/owner/repo/issues/123
https://github.com/shoptet/sofa/pull/456
owner/repo#123
https://github.com/owner/repo/issues/123#issuecomment-123456789
";
let substitution = "[\\1#\\2\\4\\7\\6](https://github.com/owner/repo/issues/\\2\\4\\5)";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}